1. Could you allow us to use the function playSound3D in our maps?

    Is there a reason why it's not allowed?


  2. 15-02-2020, 01:50
    Developer

    171 • 1,502 • 3
    In-game: Cynthia
    Re: Why is playSound3D disabled? 15-02-2020, 01:50 • #2
    Please provide your code.
    Gamespy alternative: http://333networks.com/


  3. Re: Why is playSound3D disabled? 15-02-2020, 10:12 • #3
    Originally Posted by PLASMA
    Please provide your code.
    Code:
    -- POLICE ELEVATOR MUSIC --
    
    function musicPlayerPolice()
            local x,y,z = getElementPosition( ajetdoor5131 ) 
    	local elevatorMusicPolice = playSound3D ("sounds/2.mp3", x, y, z, true)
    	    setSoundMaxDistance (elevatorMusicPolice, 35)
    	    setSoundVolume ( elevatorMusicPolice, 0.7 )
    	    attachElements ( elevatorMusicPolice, ajetdoor5131 )
    end
    addEventHandler("onClientResourceStart", resourceRoot, musicPlayerPolice)
    The attached object (ajetdoor5131) is there in my script, I didn't include it here obviously.
    This worked completely fine in the Map Editor, but when I play the map in PTP I don't hear anything. I think I even turned off the radio in settings, and turned on the map music (In case that was the reason).


  4. 15-02-2020, 12:30
    Developer

    171 • 1,502 • 3
    In-game: Cynthia
    Re: Why is playSound3D disabled? 15-02-2020, 12:30 • #4
    Cant search for this issue if you get constantly spammed by errors... Fix your scripts bro!

    mta-screen_2020-02-15_11-28-41.png
    Gamespy alternative: http://333networks.com/


  5. Re: Why is playSound3D disabled? 15-02-2020, 12:35 • #5
    Originally Posted by PLASMA
    Cant search for this issue if you get constantly spammed by errors... Fix your scripts bro!

    mta-screen_2020-02-15_11-28-41.png
    Damn, this is actually not my script. I just copied it and edited stuff in it. Anyway thanks for the heads up, I'll see what I can do.

  6. Re: Why is playSound3D disabled? 15-02-2020, 16:12 • #6
    My maps don't have the audio currently, I removed them before because it didn't work.

    However...I just uploaded an update, so now my map Exposed (not Exposed 2) should have music in the elevator.

1 Users reading this thread (0 Members and 1 Guests)